Echoes Corsac.net - Echoes camshot
mercredi 11 juin 2008 (2 posts)

Bon, y'a pleins de posts sur le net, pour savoir comment déclarer online en utilisant une Debian. Je donne juste ma petite procédure qui a marché pour moi, parce que même en lisant à droite à gauche, ça a pas marché du premier coup.

Cette solution marche au 11 juin 2008, sur une Debian Sid amd64. Vue la procédure, elle marchera aussi sur tout système Debian x86/amd64. Le principe est d'utiliser une chroot i386 propre, dans laquelle on n'installe que le strict minimum.

Let's go:

# tout d'abord les packages
corsac@hidalgo: sudo aptitude -R install cdebootstrap chroot

# On crée la chroot sid i386
corsac@hidalgo: sudo cdebootstrap -a i386 sid chroot http://ftp.fr.debian.org/debian

# On bind-mount le /tmp pour avoir un Xorg fonctionnel dans la chroot
corsac@hidalgo: sudo mount -o bind /tmp debian/chroot/tmp

# On entre dans la chroot :
corsac@hidalgo: sudo chroot debian/chroot /bin/bash

# On configure apt :
root: echo "deb http://ftp.fr.debian.org/debian/ sid main contrib non-free" > /etc/apt/sources.list
root: aptitude update

# On installe les bons packages :
root: aptitude -R install iceweasel sun-java5-plugin

# On ajoute un user histoire de pas faire ça en root :
root: adduser corsac

# C'est tout dans la chroot pour l'instant

Ensuite on copie deux choses dans la chroo :

  • le certificat (disons corsac.p12) contenant la bi-clé, que vous aurez exporté de votre navigateur courant. Si vous n'avez pas de certificat, pas de problème, vous pourrez le générer au moment de la déclaration.
  • le .Xauthority, afin de pouvoir avoir du X dans la chroot

 corsac@hidalgo: cp ~/.Xauthority debian/chroot/home/corsac/

On peut re-rentrer dans la chroot et terminer le travail :

corsac@hidalgo: sudo chroot debian/chroot /bin/bash

root: su - corsac

# On exporte le DISPLAY pour utiliser le X local
corsac: export DISPLAY=:0.0

# tout est prêt, on peut lancer les choses :
corsac: iceweasel

Normalement tout se passe bien, avec une sid à jour c'est Iceweasel 3.0rc2 qui est utilisé, et y'a pas de lien à faire ni de LD_LIBRARY_PATH à utiliser. J'ai vainement tenté d'utiliser java6, et je me tapais sans arrêt l'erreur 100, ou alors juste des cadres gris au moment de la signature de la déclaration.

Enfin, n'hésitez pas à partir d'une chroot propre, ça peut aider. Peut sans doute aider aussi de nettoyer le répertoire contenant la bibliothèque importée par le site, ~/.TaoUSign et de virer tous les vieux .so.

Voilà, hope that helps, et pour une fois les commentaires sont ouverts.

Corsac@23:35:46 (Echoes)

Images
Stats
  • 1526 posts
  • 7928 jours
  • 0.19 posts/jour
  • IRC
  • Last.fm
Stuff
Tech
Weblogs
Desktop